Tarantula pro lcd swapping between screens
#1
<p><br></p><p>This is probably the 8th 3d printer I've assembled but the first to not work straight away.<br></p><p align="center">&nbsp;</p><p class="sceditor-nlf">Assembled tarantula pro , taking time to do everything properly and in correct sequence. Leveled bed manually. <br>Checked wiring<br>switched on unit for the first time. <br>LCD screen activates. I notice a click coming from the piezo buizzer on the lcd board every few seconds.<br>Screen showed 25C room temperature as expected. <br><br>Generally menu seemed unresponsive as I was unable to easily select any of the screens. managed to get to X,Y,Z homing screens - and rhe homing all went well.<br>
<!--StartFragment-->Screen informed me that no SD card inserted which was true.<!--EndFragment-->

<br>retrieved SD card from the Tevo box and inserted it. <br>Lcd screen acknowledged the card.<br>The clicking sound increased in frequency to about 2 per second. The screen jumps on each click from the&nbsp; screen to a screen showing what I think is the bed and maybe hot end temperature. <br>I've checked all thew wiring and everything is connected. All end stops in place, heat bed connected.<br><br>Has anyone any idea what the problem may be?<br><br>Thanks in advance<br><br><br><br></p><p class="sceditor-nlf"><br></p><p class="sceditor-nlf"><br></p><p class="sceditor-nlf"><br></p><p class="sceditor-nlf"><br></p>
  Reply


Messages In This Thread
Tarantula pro lcd swapping between screens - by JeffT - 10-04-2019, 12:22 PM
LCD screen swapping update - by JeffT - 10-19-2019, 08:53 AM



Users browsing this thread: 1 Guest(s)